Managing User Workspaces


The current user's session information, including the windows size and layout, opened documents and their windows, the menu bar, toolbars, the status bar, etc., can be saved as a user's workspace in the Windows Registry for future restoration.

Configuring Workspaces

Several GUI components can be configured as needed. Just follow the instructions below and experiment with them.

Toolbars

Use Tools>Customize... to invoke the Customize dialog. From the Toolbars tab, check or uncheck the named toolbars as desired. You can also turn on or off tooltips (little labels showing longer descriptions of the toolbars when the mouse pointer is moved into the toolbar buttons), cool look (flat toolbar buttons), and large buttons (with text labels) according to your needs.

Click on the New... button to create a new named toolbar. Choose a unique name and enter it into the New Toolbar dialog. Once you press the OK button, an empty floating toolbar will appear. Click on the Commands tab in the Customize dialog. You can then select any items from the Categories and drag the toolbar buttons into the new floating toolbar you've just created. The toolbar size will be enlarged to accommodate the buttons you drag into it.

You can delete a custom toolbar by selecting it from the Toolbars list in under the Toolbars tab and click on the Delete button. The SansGUI toolbars cannot be deleted.

You can also access a simpler Toolbars configuration dialog via View>Tool bar. The properties found in the dialog is similar to those in the Customize dialog.

Menu Bar

The Menu Bar under the window title contains pull-down menu items for user operations. You can drag it around in order to dock it at any side of the main SansGUI window, or just make it a floating window. If your screen has a low resolution and you need every pixel in the vertical lines of the screen, you can dock the Menu Bar vertically.

Status Bar

The Status Bar contains a message line at the bottom of the window. It can be turned on or off by using the View>Status Bar pull-down menu item. When you need more height in the workspace, you can turn off the Status Bar.

Object Toolbox

The Object Toolbox contains two sub-windows: one for the Current Selection and the other is for the Latest Selections. You can drag the Object Toolbox around by its handle (two small bars at the side of the window) and make it float. When you click on an object from the Latest Selections, the object will be made current. The Object Toolbox is essential when you are creating parts on a Canvas View. You can close it by using the View>Object Toolbox menu item, or just click on the x button in the window's title frame.

Workbook Mode

By default, SansGUI display the workspace with multiple document loaded into the environment in a Workbook Mode. It has a tab for each loaded document in the workspace. Clicking on any of the tab will activate the associated document.

If you turn off the Workbook Mode, you will need to use the operations under the Window pull-down menu to arrange documents and activate a document. The operations are similar to those of other standard Windows applications.

Pan Instantly

By default, SansGUI will make Canvas Views synchronized with any user's pan operations, from the Ctrl key and mouse dragging sequence or from the Pan Window. If you have a large project containing many parts and links or your computer is not powerful enough to pan the Canvas View smoothly, you can turn off the Pan Instantly flag by selecting the View>Pan Instantly menu item. This operation will not affect the scrollbar operations, which will always update the Canvas View instantly.

Storing Workspaces

To store a workspace, you can use File>Save Workspace As or File>Save Workspace menu item, similar to File>Save As and File>Save operations for files. You need to name the workspace so that it can be retrieved later. The workspace is stored in the Windows Registry.

Retrieving Workspaces

To retrieve a previously saved workspace, you can use File>Open Workspace and then select one from the list, or select a recent workspace from the File>Recent Workspaces menu items. You can use the Open or Save Workspace dialog to maintain the workspaces in Windows Registry. Operations are reordering (moving workspaces up and down), creating new workspaces, and deleting existing workspaces.

Workspace Persistence

To make your workspace persist for the next session, you need to at least save one workspace and then check the Load Last Workspace at Startup menu item in the File menu.

Dialog Persistence

The positions and sizes of Graphics dialogs, Plot Results dialogs, the Properties dialogs of classes, objects, parts and links, are preserved prior to closing and used next time when they are opened. Execution dialogs, those who can remain opened while a simulation is running, persist across sessions, that is, they are automatically opened when a documented is loaded into the SansGUI Environment. Currently, Execution dialogs include Graphics dialogs and Plot Results dialogs. You can close all the execution dialogs of a document by selecting Tools>Close Execution Dialogs from the pull-down menu.

 



C:\FH_Suite\htmlgifs\home.gif Customizing SansGUI Environment Tuning Environment Parameters

SansGUI Modeling and Simulation Environment Version 1.2

Copyright 2000-2003 ProtoDesign, Inc. All rights reserved.

http://protodesign-inc.com